LAB ASSIGNMENTS

RIP

RIP v2

Routing Information Protocol Version 2.0

Objective:

Configure RIPv2 between R1 and R2 to obtain connectivity between Networks


Directions:

  • Configure R1's interface F0/0 with the IP address 10.1.0.1/16
  •  Configure R2's interface F0/0 with the IP address 10.2.0.2/16
  •  Configure R1's interface F0/1 with the IP address 12.0.0.1/8
  •  Configure R2's interface F0/1 with the IP address 12.0.0.2/8
  •  Configure RIP version 1 on R1 and R2

All active interfaces on R1 and R2 should participate in RIPv1 routing

Ask Yourself

  • What is the difference between RIPv1 and RIPv2?
  •  How does RIPv2 transmit updates?
  •  How does RIPv2 deal with fixed-length subnetted networks?
  • How does RIPv2 deal with variable-length subnetted networks?

Final Configuration:

R1:

R1>enable
R1#config Terminal
R1(config)#interface f0/0
R1(config-if)#ip address 10.1.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface f0/1
R1(config-if)#ip address 12.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-Router)#Version 2.0
R1(config-Router)#no auto-summary
R1(config-Router)#Network 10.0.0.0
R1(config-Router)#Network 12.0.0.0

R2:

R2>enable
R2#config Terminal
R2(config)#interface f0/0
R2(config-if)#ip address 10.2.0.2 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface f0/1
R2(config-if)#ip address 12.0.0.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-Router)#Version 2.0
R2(config-Router)#no auto-summary
R2(config-Router)#Network 10.0.0.0
R2(config-Router)#Network 12.0.0.0

Verification:

R1#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B – BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

R       10.0.0.0/8 [120/1] via 12.0.0.2, 00:00:04, FastEthernet0/1
C       10.1.0.0/16 is directly connected, FastEthernet0/0
C    12.0.0.0/8 is directly connected, FastEthernet0/1

R2#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B – BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set
10.0.0.0/16 is subnetted, 2 subnets

R       10.1.0.0 [120/1] via 12.0.0.1, 00:00:09, FastEthernet0/1
C       10.2.0.0 is directly connected, FastEthernet0/0
C    12.0.0.0/8 is directly connected, FastEthernet0/1

R1#show ip protocols

Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 11 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface             Send  Recv  Triggered RIP  Key-chain
FastEthernet0/0       2     2    
FastEthernet0/1       2     2

Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
12.0.0.0

Passive Interface(s):
Routing Information Sources:
     Gateway         Distance      Last Update
     12.0.0.2             120      00:00:00
     10.12.0.2            120      00:04:08
Distance: (default is 120)


R1#debug ip rip

RIP protocol debugging is on
R1#RIP: received v2 update from 12.0.0.2 on FastEthernet0/1
10.0.0.0/8 via 0.0.0.0 in 1 hops
RIP: sending  v2 update to 224.0.0.9 via FastEthernet0/0 (10.1.0.1)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 2, tag 0
10.2.0.0/16 via 0.0.0.0, metric 16, tag 0
12.0.0.0/8 via 0.0.0.0, metric 1, tag 0
RIP: sending  v2 update to 224.0.0.9 via FastEthernet0/1 (12.0.0.1)
RIP: build update entries
10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
RIP: received v2 update from 12.0.0.2 on FastEthernet0/1
10.0.0.0/8 via 0.0.0.0 in 1 hops


R1#debug ip packet

Packet debugging is on
R1#

IP: s=12.0.0.2 (FastEthernet0/1), d=224.0.0.9len 52, rcvd 2 IP: s=10.1.0.1 (local), d=224.0.0.9 (FastEthernet0/0), len 72, sending broad/multicast
IP: s=12.0.0.1 (local), d=224.0.0.9 (FastEthernet0/1), len 52, sending broad/multicast
IP: s=12.0.0.2 (FastEthernet0/1), d=224.0.0.9 len 52, rcvd 2



For More Assignments Contact NetTech

RIP v1

Routing Information Protocol Version 1.0
RIPv1 Contiguous Networks

Objective:

Configure RIPv1 between R1 and R2 to obtain connectivity between Networks


Directions:

  • Configure R1's interface F0/0 with the IP address 10.1.0.1/16
  •  Configure R2's interface F0/0 with the IP address 20.2.0.1/16
  •  Configure R1's interface F0/1 with the IP address 12.0.0.1/16
  •  Configure R2's interface F0/1 with the IP address 12.0.0.2/16
  •  Configure RIP version 1 on R1 and R2

All active interfaces on R1 and R2 should participate in RIPv1 routing

Ask Yourself

  • What is the difference between RIPv1 and RIPv2?
  •  How does RIPv1 transmit updates?
  •  How does RIPv1 deal with fixed-length subnetted networks?
  •  How does RIPv1 deal with variable-length subnetted networks?

Final Configuration:

R1:

R1>enable
R1#config Terminal
R1(config)#interface f0/0
R1(config-if)#ip address 10.1.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface f0/1
R1(config-if)#ip address 12.0.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-Router)#Network 10.0.0.0
R1(config-Router)#Network 12.0.0.0

R2:

R2>enable
R2#config Terminal
R2(config)#interface f0/0
R2(config-if)#ip address 20.2.0.1 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface f0/1
R2(config-if)#ip address 12.0.0.2 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-Router)#Network 20.0.0.0
R2(config-Router)#Network 12.0.0.0

Verification:

R1#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B – BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set
     10.0.0.0/16 is subnetted, 1 subnets
C 10.1.0.0 is directly connected, FastEthernet0/0
     12.0.0.0/16 is subnetted, 1 subnets
C 12.0.0.0 is directly connected, FastEthernet0/1
R    20.0.0.0/8 [120/1] via 12.0.0.2, 00:00:07, FastEthernet0/1

R2#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B – BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R    10.0.0.0/8 [120/1] via 12.0.0.1, 00:00:10, FastEthernet0/1
12.0.0.0/16 is subnetted, 1 subnets
C 12.0.0.0 is directly connected, FastEthernet0/1
20.0.0.0/16 is subnetted, 1 subnets
C 20.2.0.0 is directly connected, FastEthernet0/0

R1#show ip protocols

Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 2 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface             Send  Recv  Triggered RIP  Key-chain
FastEthernet0/0       1     2 1  
FastEthernet0/1       1     2 1  


Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
12.0.0.0

Passive Interface(s):
Routing Information Sources:
     Gateway         Distance      Last Update
     12.0.0.2             120      00:00:11
Distance: (default is 120)


R1#debug ip rip

RIP protocol debugging is on
R1#RIP: received v1 update from 12.0.0.2 on FastEthernet0/1
20.0.0.0 in 1 hops
RIP: sending  v1 update to 255.255.255.255 via FastEthernet0/0 (10.1.0.1)
RIP: build update entries
network 12.0.0.0 metric 1
network 20.0.0.0 metric 2
RIP: sending  v1 update to 255.255.255.255 via FastEthernet0/1 (12.0.0.1)
RIP: build update entries
network 10.0.0.0 metric 1
RIP: received v1 update from 12.0.0.2 on FastEthernet0/1
20.0.0.0 in 1 hops
RIP: sending  v1 update to 255.255.255.255 via FastEthernet0/0 (10.1.0.1)
RIP: build update entries
network 12.0.0.0 metric 1
network 20.0.0.0 metric 2
RIP: sending  v1 update to 255.255.255.255 via FastEthernet0/1 (12.0.0.1)
RIP: build update entries
network 10.0.0.0 metric 1

RIP: received v1 update from 12.0.0.2 on FastEthernet0/1
20.0.0.0 in 1 hops



RIPv1 Discontiguous Networks

Objective: Configure RIPv1 between R1 and R2 to obtain connectivity between Networks



Directions

  •  Configure R1's interface F0/0 with the IP address 10.1.0.1/16
  •  Configure R2's interface F0/0 with the IP address 10.2.0.2/16
  •  Configure R1's interface F0/1 with the IP address 12.0.0.1/8
  •  Configure R2's interface F0/1 with the IP address 12.0.0.2/8
  •  Configure RIP version 1 on R1 and R2

All active interfaces on R1 and R2 should participate in RIPv1 routing

Ask Yourself

  • What is the difference between RIPv1 and RIPv2?
  • How does RIPv1 transmit updates?
  • How does RIPv1 deal with fixed-length subnetted networks?
  • How does RIPv1 deal with variable-length subnetted networks?

Final Configuration:

R1:

R1>enable
R1#config Terminal
R1(config)#interface f0/0
R1(config-if)#ip address 10.1.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface f0/1
R1(config-if)#ip address 12.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-Router)#Network 10.0.0.0
R1(config-Router)#Network 12.0.0.0

R2:
R2>enable
R2#config Terminal
R2(config)#interface f0/0
R2(config-if)#ip address 10.2.0.2 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface f0/1
R2(config-if)#ip address 12.0.0.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-Router)#Network 10.0.0.0
R2(config-Router)#Network 12.0.0.0

Verification:

R1#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B – BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route


Gateway of last resort is not set

10.0.0.0/16 is subnetted, 1 subnets
C  10.1.0.0 is directly connected, FastEthernet0/0
C 12.0.0.0/8 is directly connected, FastEthernet0/1

R2#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B – BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route


Gateway of last resort is not set

10.0.0.0/16 is subnetted, 1 subnets
C 10.2.0.0 is directly connected, FastEthernet0/0
C 12.0.0.0/8 is directly connected, FastEthernet0/1

R1#show ip protocols

Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 20 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface             Send  Recv  Triggered RIP  Key-chain
FastEthernet0/0       1     2 1  
FastEthernet0/1       1     2 1  


Automatic network summarization is in effect
Maximum path: 4

Routing for Networks:
10.0.0.0
12.0.0.0

Passive Interface(s):
Routing Information Sources:
Gateway         Distance      Last Update
Distance: (default is 120)

R1#debug ip rip

RIP protocol debugging is on
R1#RIP: received v1 update from 12.0.0.2 on FastEthernet0/1
10.0.0.0 in 1 hops
RIP: sending  v1 update to 255.255.255.255 via FastEthernet0/0 (10.1.0.1)
RIP: build update entries
network 12.0.0.0 metric 1
RIP: sending  v1 update to 255.255.255.255 via FastEthernet0/1 (12.0.0.1)
RIP: build update entries
network 10.0.0.0 metric 1
RIP: received v1 update from 12.0.0.2 on FastEthernet0/1
10.0.0.0 in 1 hops
RIP: sending  v1 update to 255.255.255.255 via FastEthernet0/0 (10.1.0.1)
RIP: build update entries
network 12.0.0.0 metric 1
RIP: sending  v1 update to 255.255.255.255 via FastEthernet0/1 (12.0.0.1)
RIP: build update entries
network 10.0.0.0 metric 1


RIPv1 FLSM

Objective: Configure RIPv1 between R1 and R2 to obtain connectivity between networks.



Directions

  •  Configure R1's interface F0/0 with the IP address 10.1.0.1/16
  •  Configure R2's interface F0/0 with the IP address 10.2.0.2/16
  •  Configure R1's interface F0/1 with the IP address 10.12.0.1/16
  •  Configure R2's interface F0/1 with the IP address 10.12.0.2/16
  •  Configure RIP version 1 on R1 and R2

All active interfaces on R1 and R2 should participate in RIPv1 routing
Ask Yourself

  •  What is the difference between RIPv1 and RIPv2?
  •  How does RIPv1 transmit updates?
  •  How does RIPv1 deal with fixed-length subnetted networks?
  •  How does RIPv1 deal with variable-length subnetted networks?

Final Configuration

R1:

R1>enable
R1#config Terminal
R1(config)#interface f0/0
R1(config-if)#ip address 10.1.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface f0/1
R1(config-if)#ip address 10.12.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-Router)#Network 10.0.0.0

R2:

R2>enable
R2#config Terminal
R2(config)#interface f0/0
R2(config-if)#ip address 10.2.0.2 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface f0/1
R2(config-if)#ip address 10.12.0.2 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-Router)#Network 10.0.0.0

Verification:

R1#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B – BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/16 is subnetted, 3 subnets
C 10.1.0.0 is directly connected, FastEthernet0/0
R 10.2.0.0 [120/1] via 10.12.0.2, 00:00:07, FastEthernet0/1
C 10.12.0.0 is directly connected, FastEthernet0/1

R2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B – BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/16 is subnetted, 3 subnets
R 10.1.0.0 [120/1] via 10.12.0.1, 00:00:18, FastEthernet0/1
C 10.2.0.0 is directly connected, FastEthernet0/0
C 10.12.0.0 is directly connected, FastEthernet0/1

R1#debug ip rip
R1#RIP: received v1 update from 10.12.0.2 on FastEthernet0/1
10.2.0.0 in 1 hops
RIP: sending  v1 update to 255.255.255.255 via FastEthernet0/0 (10.1.0.1)

RIP: build update entries
network 10.2.0.0 metric 2
network 10.12.0.0 metric 1
RIP: sending  v1 update to 255.255.255.255 via FastEthernet0/1 (10.12.0.1)

RIP: build update entries
network 10.1.0.0 metric 1
RIP: received v1 update from 10.12.0.2 on FastEthernet0/1
10.2.0.0 in 1 hops
RIP: sending  v1 update to 255.255.255.255 via FastEthernet0/0 (10.1.0.1)
RIP: build update entries
network 10.2.0.0 metric 2
network 10.12.0.0 metric 1
RIP: sending  v1 update to 255.255.255.255 via FastEthernet0/1 (10.12.0.1)
RIP: build update entries
network 10.1.0.0 metric 1
RIP: received v1 update from 10.12.0.2 on FastEthernet0/1
10.2.0.0 in 1 hops


RIPv1 VLSM

Objective: Configure RIPv1 between R1 and R2 to obtain connectivity between Networks


Directions

  •  Configure R1's interface F0/0 with the IP address 10.1.0.1/16
  •  Configure R2's interface F0/0 with the IP address 10.2.0.2/24
  •  Configure R1's interface F0/1 with the IP address 10.12.0.1/16
  •  Configure R2's interface F0/1 with the IP address 10.12.0.2/24
  • Configure RIP version 1 on R1 and R2

All active interfaces on R1 and R2 should participate in RIP routing
Ask Yourself

  •  What is the difference between RIPv1 and RIPv2?
  •  How does RIPv1 transmit updates?
  •  How does RIPv1 deal with fixed-length subnetted networks?
  •  How does RIPv1 deal with variable-length subnetted networks?
  •  How will the difference in subnet mask of R1 and R2 affect the behavior of

 RIP?

Final Configuration:
R1:

R1>enable
R1#config Terminal
R1(config)#interface f0/0
R1(config-if)#ip address 10.1.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface f0/1
R1(config-if)#ip address 10.12.0.1 255.255.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-Router)#Network 10.0.0.0

R2:

    R2>enable
    R2#config Terminal
    R2(config)#interface f0/0
    R2(config-if)#ip address 10.2.0.2 255.255.255.0
    R2(config-if)#no shutdown
    R2(config-if)#exit

Verification:
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B – BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2, E – EGPi - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area* -candidate default, U - per-user static route, o – ODRP - periodic downloaded static route

Gateway of last resort is not set
10.0.0.0/16 is subnetted, 3 subnets
C 10.1.0.0 is directly connected, FastEthernet0/0R
10.2.0.0 [120/1] via 10.12.0.2, 00:00:06, FastEthernet0/1
C      
10.12.0.0 is directly connected, FastEthernet0/1

R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B – BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2, E – EGPi - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area* -candidate default, U - per-user static route, o – ODR P - periodic downloaded static route


Gateway of last resort is not set
10.0.0.0/24 is subnetted, 3 subnetsR
10.1.0.0 [120/1] via 10.12.0.1, 00:00:20, FastEthernet0/1
C     
10.2.0.0 is directly connected, FastEthernet0/0C    
10.12.0.0 is directly connected, FastEthernet0/1

For More Assignments Contact NetTech

scroll up